Thinkphp框架升级后出现baseQuery::jsonResult()错误的解决方案
糊涂粥 于 2021-12-13 16:02:57

Thinkphp更新到了6.0.9,我升级后发现原来运行正常的代码会报类似这样的错误

think\db\baseQuery::jsonResult(): Argument #1 ($result) must be of type array.....

发现是因为升级过程中,

topthink/think-orm 从2.0.44升级到了2.0.45,将期版本降级至2.0.44,问题就可以解决。

如果已经升级了应该怎么降级呢?

将composer.json文件中的

"topthink/think-orm": "^2.0"

改为

"topthink/think-orm": "2.0.44"

然后运行

 composer update
即可。
阅读 (372)